AGNPH Forums

Old Site General Bugs

 
  •  
    Friendly resident Cyndaquil
    Cyn
    Date: Jul 3, 2013 8:54 AM(Edited: Feb 25, 2015 5:16 PM) Title: Old Site General Bugs

    And to start off the support desk lobby, the first new site bug(s)!

    Bugs in Progress


    • None ;D

    Ouroboros Bugs

    • Pages past 1000 cannot be navigated
      After page 1000, the scroll links become Prev and Next, but those don't work correctly.
    • Tag aliasing is broken
      Tags cannot be aliased together.
    • Artist search is broken
      Searching the list of artists results in a 500 error. Also, japanese characters can't be searched for.

    Bug History

    • Resolved Private messages have a 20/hr limit
      Flygon is investigating why PM's are being rate limited.
      EDIT:This limit is intentional to stop DoS attacks. Use IRC if you want to send messages more frequently.
    • Ouroboros devs notified Empty pages in Gallery
      If you search for "tagme", the last couple of pages are empty with the message "No posts matched your search."
      EDIT: In addition, for pages near the end of the list of results (> page 1000), the previous and next buttons are quite broken (redirect to either the same page or the wrong page).
      EDIT (HatchlingByHeart): Advice from Lead Developer of Ouroboros / Workaround: This is caused by images that were deleted but not destroyed (images still exist but are hidden). This issue is not site breaking as long as you remember to quit browsing further pages once you hit your first blank page, just pretend it's the end of the list. There's a huge backlog of deleted images that need to be restored or permanently destroyed, and Gallery Admins have been instructed to immediately destroy any deleted images in future and for admins and users alike to use the Flag for Deletion feature if they think an image should be removed from the gallery instead of just deleting it.
    • Resolved Image hover username
      For names like HatchlingByHeart (which are most of the images), the name field overflows the hover box that pops up.
    • Resolved Fics registration missing CAPTCHA
      Registering for the forums is missing a CAPTCHA, and spambots have appeared.
    • Resolved Issues editing gallery
      First noticed here and confirmed by me. Users encountering error messages when trying to edit posts in the gallery even after the 3-day waiting period. Users can successfully edit tags by going into edit mode on the posts page, but cannot edit posts individually by clicking "edit" under the sidebar options of a single post. Error message is "Error: You cannot edit post parents during your first week", even though parent post field was unchanged. Resolution: Waiting period has been changed to 24 hours.
    • Resolved Gallery Security Certificate
      Registering and/or logging into the gallery presents users with a security certificate error.
    • Resolved Forum post headers wrap
      When the browser width is low, the post headers wrap and are cut off. Fixed for two lines, but still cuts off when the title wraps for three lines.
    • Resolved Fics section RSS Feed
      The most recent fics RSS feed still has links that point back to the old fics section URL (agn.ph/fics/). RSS feed is located here, accessible from the Most Recent page via the XML button.
    • Resolved Favicon
      The site favicon only loads on the news, gallery and oekaki pages (in chrome) and gallery and oekaki pages (in firefox).
    • Resolved Fics links
      If you navigate to the Challenges section of the fics, all the navbar link images are broken.
    • Resolved Forums new topic button
      New topics were allowed in the news subforum, then locked on all subfourms.
    • Resolved Inability to modify Custom User Titles
      You can add a Personal Text tagline (See Left, "Friendly resident Cyndaquil"), but cannot edit the Custom User Titles ("I draw my own avatar").
    • Resolved PM Reply Button
      Reply button for PM's was either missing or scrolled off the page so you can't click it. Edit: Also, the delete PM button is hidden as well.
    • Resolved Fics section Skin
      Fics section still has some CSS issues with font color (e.g. Most Recent page) where text is extremely hard to read. Also, footer "-2012 AGNPH" box color and it's not 2012.

    siYrw.gif
    ~My fire shall always burn eternal~

     
     
  •  
    Flygon did it...
    HatchlingByHeart
    Date: Jul 4, 2013 9:01 AM(Edited: Jul 4, 2013 11:13 AM) Title: Re: General Bugs (I'll update this as I find them or they get resolved)
    Strike off the favicon. It's not a bug, I just haven't included favicons for the sections they don't show up in yet. I'm working on a new one.

    EDIT: Also, stickied.

     
     
  •  
    Flygon did it...
    HatchlingByHeart
    Date: Jul 4, 2013 11:18 AM Title: Re: General Bugs (I'll update this as I find them or they get resolved)
    "Inability to modify Custom User Titles"

    Should work now. Please test and strike this out if successful.

     
     
  •  
    Illusionairy Fox
    Chief
    Date: Jul 4, 2013 12:06 PM Title: Re: General Bugs (I'll update this as I find them or they get resolved)
    Confirmed that "Custom Title" is unlocked and modifiable.

     
     
  •  
    Flygon did it...
    HatchlingByHeart
    Date: Jul 4, 2013 5:31 PM Title: Re: General Bugs (I'll update this as I find them or they get resolved)
    "Fics links"

    This issue is resolved and links are now confirmed to work in the Challenges section.

     
     
  •  
    I probably don't like you.
    Blippy
    Date: Jul 4, 2013 5:36 PM Title: Re: General Bugs (I'll update this as I find them or they get resolved)
    Post headers wrap incorrectly and cut off text if the thread title is too long.

    OATAut8.jpg

     
     
  •  
    Flygon did it...
    HatchlingByHeart
    Date: Jul 4, 2013 5:42 PM(Edited: Jul 4, 2013 5:46 PM) Title: Re: General Bugs (I'll update this as I find them or they get resolved)
    Right as you post that, I was already working on fixing this. :P

    EDIT: Fixed.

     
     
  •  
    BioPhoenix
    Date: Jul 4, 2013 8:05 PM Title: Re: General Bugs (I'll update this as I find them or they get resolved)
    On the home page, it seems like the announcements are in the order that the last reply was given, rather than in the order they were posted in.

    Also, on the gallery, doing certain things, including accessing the "My Account" page, says that the site is giving an invalid security certificate.

     
     
  •  
    Flygon did it...
    HatchlingByHeart
    Date: Jul 5, 2013 11:05 AM Title: Re: General Bugs (I'll update this as I find them or they get resolved)
    There's been so many issues with the front page news that I'm just considering removing them until I can code my own system for them. At the moment I'm using Simple Machine Forum's SSI system to show the posts, which always assumes we want to see the latest post, not the earliest one.

     
     
  •  
    Flygon did it...
    HatchlingByHeart
    Date: Jul 5, 2013 3:43 PM Title: Re: General Bugs (I'll update this as I find them or they get resolved)
    The Gallery certificate issue has been resolved. I'll update the thread.

     
     
<<1234>><<12...4>>